Vodafone Billing Outage
Incident Report for ImpulsePay
Resolved
Vodafone billing has returned to normal and has now remained stable since 12:10 yesterday.
Posted over 2 years ago. Sep 13, 2016 - 08:26 BST
Identified
Vodafone is experiencing an outage of its billing service.

We have raised this with their technical teams and will update this notice as and when we receive feedback.
Posted over 2 years ago. Sep 12, 2016 - 10:11 BST