Three Billing Outage
Incident Report for ImpulsePay
Resolved
This incident has been resolved.
Posted almost 3 years ago. Aug 27, 2016 - 19:03 BST
Monitoring
Three have confirmed an outage of their billing service.

We await further updates and will advise accordingly.
Posted almost 3 years ago. Aug 27, 2016 - 10:38 BST