Delayed Billing
Incident Report for ImpulsePay
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jun 28, 2017 - 17:30 BST
Monitoring
Timely billing has been restored as of 9:15pm - our engineers are continuing to monitor the situation.
Posted almost 2 years ago. Jun 23, 2017 - 00:41 BST
Investigating
We are currently experiencing a delay in the sending of billed messages.

Engineers are investigating the issue and will provide updates accordingly.
Posted almost 2 years ago. Jun 22, 2017 - 19:29 BST