Three Maintenance
Incident Report for ImpulsePay
Resolved
Three have restored billing system.
Posted over 2 years ago. Oct 23, 2016 - 11:31 BST
Monitoring
Three have begun maintenance to their billing system causing billing to be down. We are monitoring the system during the maintenance window.
Posted over 2 years ago. Oct 22, 2016 - 22:49 BST