Payment pages service outage
Incident Report for ImpulsePay
Resolved
Payment Pages connection has been fixed and all the services returned to normal.
Posted over 2 years ago. Oct 11, 2016 - 18:02 BST
Investigating
We are currently experiencing an outage of our payment pages service.
Our technicians are working on it and all the updates will be posted to this notice.
Posted over 2 years ago. Oct 11, 2016 - 17:38 BST