EE Outage
Incident Report for ImpulsePay
Resolved
This incident has now been resolved.
Posted 8 months ago. Aug 24, 2018 - 12:00 BST
Investigating
Dear Valued Merchant,

Please be advised of an outage effecting the following service:

EE

Our engineers are currently looking into the fault and will update this status once there is more to report.

Regards,
ImpulsePay
Posted 8 months ago. Aug 24, 2018 - 10:34 BST