Three Emergency Maintenance
Incident Report for ImpulsePay
Resolved
This incident has been resolved.
Posted almost 3 years ago. Aug 30, 2016 - 11:36 BST
Monitoring
The Three billing system is working.

We will continue to monitor the stability of the connection.
Posted almost 3 years ago. Aug 30, 2016 - 08:42 BST
Identified
Three are undertaking emergency maintenance of their billing infrastructure. We expect this to be completed by 10am and will provide further updates as we receive them.
Posted almost 3 years ago. Aug 30, 2016 - 04:45 BST