Three Billing Service Outage
Incident Report for ImpulsePay
Resolved
This incident has been resolved.
Posted over 2 years ago. Nov 14, 2016 - 16:36 GMT
Monitoring
The Three billing system is working.
We will continue to monitor the stability of the connection.
Posted over 2 years ago. Nov 14, 2016 - 14:36 GMT
Investigating
Three have identified an issue with their billing service and are working to resolve the problem.
Posted over 2 years ago. Nov 14, 2016 - 10:24 GMT