Three Billing Service Outage
Incident Report for ImpulsePay
Resolved
Three have resolved the issue.
Posted over 2 years ago. Nov 09, 2016 - 15:05 GMT
Investigating
Three are experiencing a Billing Service Outage and their engineers are investigating the issue and working towards a resolution.
Posted over 2 years ago. Nov 09, 2016 - 11:43 GMT